Back to overview
Maintenance
FortePriv Maintenance
Jun 06 at 06:00pm GMT+3
–
Jun 14 at 08:00pm GMT+3
Affected services
FORTE
Resolved
Jun 06 at 06:00pm GMT+3
Transition to New Infrastructure
Affected services
FORTE
Resolved
Jun 06 at 06:00pm GMT+3
Transition to New Infrastructure
Affected services
FORTE